Installation (Dokumentation)


#1

Halli Hallo,

Leider komm ich mit dem Wiki nicht so ganz klar.
Ich habe mir den Zip - Ordner runtergeladen.

Kann auch diese Konsole öffnen / Installation Mysql und dann?

Wenn jemand vom Team mir das schritt für schritt erklären würde, würde ich eine installations doku
schreiben und veröffentlichen ich denke das schreck auch noch einge ab!

Diese datein kann ich dann per pdf zur Verfügung stellen und auch gerne das wiki damit füttern.

Danke schonmal im vorraus!


#2

Hallo Sascha,
ein Offline Handbuch ist in Arbeit.
Dieses stützt sich inhaltlich weitestgehend auf das Wiki.
Das Wiki ist eigentlich eine detaillierte Anleitung.

An welchem Punkt genau hast Du Probleme weiter zukommen?


#3

Hallo, ich habe mittlerweile auch schon einige Stunden vor meinem PC verbracht ohne wirklich groß weiter gekommen zu sein. Gibt es eigentlich keine Schritt für Schritt Anleitung. Man muss in vielen verschiedenen Stellen suchen und viele Bereich sind dann gar nicht beschrieben.
Man muss sich die beiden zip-Dateien downloaden und entpacken, anschließend in das Verzeichnis “C:\inetpub\wwwroot” kopieren. Muss man den Inhalt der beiden entpackten Verzeichnisse dorthin kopieren oder nur den Inhalt der Webseite. Wenn ich den Konfigurationseditor öffne, wie bekomme ich da etwas rein?
Ich bin sicher nicht ganz unbedarft, aber mir fehlen sehr viele Schritte. Mich hätte die Software für unsere Feuerwehr sehr interessiert, aber im Moment bin ich stark am spekulieren, ob ich es wieder aufgebe.

Viele Grüße Georg


#4

Hallo Georg,

Danke für Deine Rückmeldung. Aktuell arbeiten wir an einem Handbuch welches wir mit der Software ausliefern und welches das Wiki ersetzen soll.
Du installierst MySQL und führst das SQL Script aus z.B. mit Heidi SQL
packages/AlarmWorkflowSchema.sql.txt

Dann entpackst Du das Archiv
packages/v0.9.5.0.exe
in einen Ordner Deiner Wahl. Darin entpackst Du die OCR dateien packages/ocrpackage.zip

Nun konfigurierst Du in der backend.config die Datenbank und installierst den Dienst. Das hast Du alles gemacht? Wo hakt es noch?
In das Verzeichnis inetpub muss nur die Webseite wenn Du diese auch verwenden willst.

Mal noch etwas am Rande. Was willst Du mit dieser Aussage erreichen?

Wir betreiben das in unserer Freizeit. Wir sind nicht darauf angewiesen das unsere Software eingesetzt wird. Da wir nichts verlangen gibt es auch keinen Anspruch auf etwas.
Wir geben unser bestes. Wenn mal etwas nicht läuft wie vorgestellt, dann meldet euch und wir versuchen dann es zu korrigieren. Aber solche Aussagen braucht keiner aus dem Team. Frohe Ostern.


#5

Das gilt im Übrigen für alle Nutzer von AlarmWorkflow. Bei Fragen oder Fehlern meldet euch bitte. Das kostet euch nichts und bringt im besten Fall allen Nutzern was, damit AW noch besser wird!


#6

Hallo zusammen,

ich kämpfe mich seit Tagen durch die verschiedenen Foren. Ich komme bisher leider nicht mit der Installation weiter.
Habe die MySQL-Datenbank, Network 4.0, Heidisql und GitHub bereits installiert. Nun stehe ich aber ein wenig im Wald.
Alarmworkflow v0.9.6.0 habe ich auch heruntergeladen. Hier müssen anscheinend noch einige Daten geändert werden.
Ich weiß aber bisher nicht was.

Unter GitHub habe ich mir auch noch die Alarmworkflow-Master - Datei geholt.
Weiß aber jetzt nicht welches ich “installieren” muß.

Kann mir vielleicht jemand einen Tip geben wie und was ich noch ändern bzw. installieren muss?

Viele Grüsse

Manfred


#7

Hi,

hast du den sql code mit heide-sql ausgeführt? und die Backend.config mit den von dir eingegeben Datenbankeinstellungen abgespeichert?

Github usw brauchst du nicht, das ist nur nötig falls du “Beta-Versionen” also noch nicht vollständig gesteste Versionen verwenden willst.

Hier mal das grobe Vorgehen (Ist aus dem Kopf zusammengeschrieben, ich hoffe ich hab nichts vergessen)

  1. MYSQL installieren (Standardeinstellungen, Passwort notieren)
  2. Hilfsprogramm fürs SQL (z.B HeidiSQL, MySQL Workbench)
  3. SQL Code aus packages/AlarmWorkflowSchema.sql.txt ausführen
  4. Aktuelle Version Alarmworkflow (z.B. packages/v0.9.6.0.exe ) herunterladen und am besten nach “C:\Alarmworkflow” entpacken
  5. Parser(übersetzt Fax ins Maschinell lesbare) herunterladen ( packages/Parser.exe ) und ins oben genannte Verzeichnis kopieren
  6. Die Datei Backend.config bearbeiten (Einstellungen aus der Mysql Installation)
  7. Alamworkflow Konfigurator das erste mal Starten -> AlarmWorkflow.Windows.Configuration.exe aufrufen
  8. Service installieren -> Rechts oben steht Service nicht installiert -> draufklicken und installieren auswählen
  9. nach der Installation Konfigurator schließen und erneut aufrufen
  10. Konfigurieren

Und dann kann man mit einem Testfax loslegen (Alternativ sollte auch ein Eintrag von Hand in der Datenbank funktionieren)

Viel Erfolg


#8

Hallo Manfred,

im Grunde hat “ks91” alles schön zusammengefasst! (Danke dafür an dieser stelle!)
Bei weiteren Fragen rühr dich.

LG
Flo


#9

Hallo,

danke für die schnelle Hilfe, hat auch fast alles geklappt. Leider habe ich noch eininge Fragen.

zu Punkt 5. muß ich hier die Parser.exe in dem Verzeichnis entpacken oder nur kopieren?

Das Ausführen der Punkte 7-9 klappte auch. Aber beim Punkt 10 blieb die Maske leider leer und ich kann nichts einstellen.

Bei mir am PC läuft Win 7 Home Premium 64 Bit. Kann das an dem liegen?

Gruß
Manfred


#10

Also:
Parser.exe müsstest entpacken.
–> Log Dateien bitte mal in seperaten Thread unter Fehler und Hilfe! (Läuft der Service?)
Am OS liegt es nicht.
Liebe Grüße
Flo


#11

Hallo, nachdem die Tage wieder kürzer werden, habe ich mich vor ein paar Tagen nach einer längeren Pause wieder aufgemacht Alarmworkflow zum Laufen zu bringen. Sehr positiv überrascht war ich von der tollen Anleitung, die ihr gemacht habt.
Jetzt stehe ich aber vor einem neuen Problem, bei dem ich überhaupt nicht weiß, wie ich es lösen sollte.
Ich habe einen PC mit Windows 7/64bit am Laufen, als “Faxgerät” sollte eine eingebaute FritzCard PCI dienen. Leider wird diese FritzCard unter "Windows Fax und Scan nicht erkannt, bzw. angezeigt. Eine Recherche über Google hat nur ergeben, dass mehrere dieses Problem haben, aber keiner eine richtige Lösung. Als Router dient eine FritzBox 7170. Ist es möglich die Informationen anderweitig “abzugreifen” oder hat jemand eine Lösung, wie meine FritzCard doch erkannt werden könnte.

Vielen Dank im Voraus
Georg


#12

Hast du es schon mit diesen Treibern versucht?
https://openfire.software/t/avm-fritz-karte/698/7


#13

Vielen Dank, das hat mich viele Schritte weitergebracht.

Grüße Georg


#14

Hallo,
mittlerweile funktionierts grundsätzlich. Ich sitze nicht täglich davor, sondern nur wenn ich Zeit übrig habe. Zwei Fragen habe ich aber wieder.
Wie sollte man die Energieoptionen einstellen, damit der Monitor nach der im Alarmworkflow eingestellten Zeit in StandBy geht und bei einem Alarm sich einschaltet. Ich habe die Erfahrung gemacht, dass von Alarmworkflow der Monitor nicht in StandBy geschickt wird. In Alarmworkflow habe ich 30min eingestellt und so habe ich es heute in den Energieoptionen auch 30min zum Abschalten des Monitors eingestellt. Der Monitor hat sich dann auch nach 30min verabschiedet, aber nach einem Testfax ging der Monitor nicht an. Habt ihr da einen Tip, wie ich die Einstellung tätigen könnte.
Meine zweite Frage betrifft die Anordnung in der UI. Ich habe da nur drei schmale Spalten (siehe Bild; ist nur abfotografiert, da ich im Gerätehaus keinen Stick dabei hatte und auch kein E-Mail-Konto eingerichtet ist), zwischendurch hatte ich auch mal vier, da ließ ich die vergangene Zeit seit dem Alarm anzeige. Kann man die Informationen automatisch anordnen lassen oder wie muss die “Teile” manuell anordnen.

Vielen Dank im Voraus

Georg


#15

Hallo,

also:
Was Energieoptionen angeht: Es gibt unter Windows - UI eine Einstellung “Screensaver … unterbinden”. Versuche mal was passiert wenn du diese aktivierst und in den Energieoptionen das Timeout auf 2 oder 3 Minuten stellst. Sprich solange ein Alarm vorliegt wird der Bildschirm aktiviert/aktiv gehalten (Mit nem kleinen Trick: Maus bewegen). Nach dem Alarm wird der Bildschirm seitens Windows wieder deaktiviert.

Sollte eigentlich funktionieren. Falls nicht bitte nochmal melden.

Zum Layout: Nein das Layout der Ansichten musst du dir händisch einstellen. Hintergrund ist, dass eine automatische Ausrichtung zu viele Faktoren berücksichtigen müsste und man selten mit einer automatisierung alle Wünsche/Vorstellungen erfüllen kann.


#16

Hallo, das mit den Energieoptionen hat funktioniert. Die Einstellung waren grundsätzlich richtig, ich habe nur die Zeit auf die besagten 2-3 min gesetzt. Was genau der Grund war, kann ich im Nachhinein nicht sagen. Jetzt habe ich ein neues Problem. Aus Versehen wurde nach einer Meldung des Virenscanners die Datei “AlarmWorkflow.Windows.UI.exe” gelöscht. Ich habe sie wieder in das Verzeichnis kopiert, aber beim Starten der UI kommt jetzt die Fehlermeldung “AlarmWorkflow.Windows.UI funktioniert nicht mehr”. Gibt es hier eine schnelle Lösung wie ich die UI wieder zum Laufen bringe?
Eine weitere Frage habe ich noch. Ich habe die Webseite über die Portfreigabe auch im Internet freigeschaltet. Es wäre nicht schlecht, wenn hier die Möglichkeit der Zugriffssteuerung möglich wäre, mit Benutzer und Passwort. Ich habe mich zwar daran versucht, aber zumindest auf die Schnelle bin ich mit den ganzen Einstellungen zu keiner Lösung gekommen.
Mit der grafischen Darstellung in der UI muss ich auf einen tatsächlichen Alarm warten, damit ich die Darstellung sehe. Es gab zwar Alarme, seitdem die Software läuft, aber der Desktopmanager wurde vorher immer deaktiviert, da ich automatische Windows Updates aktiviert hatte und so stand die Maschine auf dem Anmeldebildschirm.
Ist evtl. ein Hinweis für alle, die Automatischen Updates für Windows zu deaktivieren.

Vielen Dank im Voraus

Georg


#17

Mhmmm mal in die Logdateien geschaut?
Grüße
Flo


#18

Dein Kommentar zum “Desktopmanager” verstehe ich nicht ganz. Kannst du versuchen das genauer zu erklären.
Mit den automatischen Windows Updates hatte ich bis jetzt noch keine Probleme. Seit wann hast du die Probleme?
Grüße
Flo


#19

Hallo,
hier ein Ausschnitt aus der Ereignisanzeige. Die automatischen WindowsUpdates waren auf 03.00 Uhr gesetzt. Es standen keine wichtigen und 8 optionale Updates an.

Grüße Georg
ereignisanzeige_20141210.txt (30 KB)


#20

Des habe ich auch noch nicht gesehen. :open_mouth:
Vielleicht kann ich das nachstellen. Das einzige was ich mir vorstellen kann ist das Windows versucht den kompletten Rechner neuzustarten. Das könnte man aber Windows austreiben (habe ich bei mir überall deaktiviert)
Grüße
Flo